Go to bug ID
Hello, guest. We have noticed that you are not registered at this bug tracker. Your experience will be greatly enhanced if you log in. To do so, you first must register by clicking on the Register tab at the top. If you are already registered, you can login at the Login tab.
Syndicate Syndicate Listing Display Search Login/Register
Bug Id ?
Reporter ?
jammydevil
Product/Version ?
Crimson Editor / Version 3.72 Beta 241
Status ?
Confirmed
Severity ?
Minor
Duplicate Of ?
- none -
Summary ?
.prj opens file in edit mode rather than opening project
Report Time ?
July 23, 2007 11:43:46 AM
Assignment ?
- none -
Resolution ?
Open
Priority ?
Low
Dependencies ?
- none -


Votes
For: 1 (100%)
Against: 0 (0%)
Total: 1

July 23, 2007 11:43:46 AM jammydevil
Opening a .prj file by double clicking it automatically opens the file in edit mode. Possibly an option to open the file in the project format.

August 9, 2007 11:34:20 PM Ankit Singla
I think there should be a checkbox in the File>Association section in CE preferences that says "Associate .prj files with Crimson Editor" or something similar to take care of this. All it would do is add a setting to the registry. I don't quite understand how open vs. open project works though. I'm not sure how easy it would be to tell if someone tried opening it to edit or opening it as a project. My instinct would be standard double click or right click>open/open with would open the actual project. But opening with "Edit with CE" should of course be edit prj file. I'm thinking associating the prj will add an option or something so you get "cedt -p <project>" instead of "cedt <project>" or something. Then CE could open projects from command line, which in and of itself would be pretty useful :)

August 29, 2007 01:07:40 AM LFLFM
Perhaps it should read the first line of any file with the ext .prj... if it reads <project version="Crimson Editor X.XX">, then its a project, try to open it.
BTW I opened a duplicate of this issue, because I used the bug search (apparently I used it incorrectly) and didn't find this listing, I tried to delete it but I couldnt. Its bug ID 73.